PHP5.6:n tuki päättyy vuodenvaihteessa

PHP5.6:n tuki ja tietoturvapäivitykset päättyvät vuodenvaihteessa 31.12.2018, jonka jälkeen versiota hyödyntävät sivustot ovat alttiita tietoturvahyökkäyksille. Viestintäviraston Kyberturvallisuuskeskus suosittelee luopumaan vanhojen PHP-versioiden käytöstä.

PHP5.6 on julkaistu vuonna 2014, ja se on edelleen käytössä laajasti monissa webpalveluissa. PHP:sta julkaistaan uusi versio noin kerran vuodessa, joka parantaa PHP:n tietoturvaa ja nopeutta sekä lisää uusia toimintoja. Viimeisin julkaistu versio on 7.3.

PHP (Hypertext Preprocessor) on yleinen webpalveluissa käytetty ohjelmointikieli. PHP-kielellä toteutettuja tai sitä hyödyntäviä sisällönhallintajärjestelmiä ja julkaisualustoja ovat mm. Drupal, Joomla, MediaWiki, Moodle, TYPO3 ja WordPress.

Lisätietoa aiheesta Viestintäviraston sivuilla. 

« Paluu

CONTACT US »
OTA
YHTEYTTÄ »

Jätä yhteydenottopyyntö

Palaamme asiaan pikimmiten!